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Read first! – Seriously, it’s important!
This guide is a supplement to the Mapper user manual. Whereas the Mapper manual is
a technical document, this guide seeks to explain the concepts of the Mapper and
introduces the features it has.
It covers most of the frequently asked support emails we get and it points out some
important things you need to know.
The Mapper, whilst fairly simple, has certain complexities that if not understood can lead
to confusion and unexpected behaviour. So it’s highly suggested that you read this
guide, all of it, and in the order it’s written. Seriously, we’re not kidding! Doing so will
save you some potentially wasted time.
Limitations in the functionality of the Tangent Mapper
• There is no copy or paste functionality.
• There is no undo functionality. Some of the features have the potential to
overwrite mappings that have been previously assigned. Before you make any
changes make a copy of your map that you can go back to in the event you
make a mistake.
• There is no auto save function, you need to periodically save any changes. You
will however be prompted if you have unsaved changes before you quit the
Mapper, or quit an application connected to the Mapper.
• You cannot create control maps for any application that does not support the
Tangent Mapper or Tangent Hub. Actually, that’s not strictly true, you can create
a map which is keyboard shortcuts only or if your application supports Open
Sound Control (OSC) you can map our panels to it. We’ll cover these later in the
guide.
Does my application support the Tangent Mapper?
This guide assumes you’re using the panel with an application that supports our panels
and our Tangent Mapper. You can check if your application supports our panels and our
Tangent Mapper by:
1. Go to your panel’s product page on our website.
2. Click the Application Support tab.
3. Then select your application.
If the application supports our panels and the Tangent Mapper it will say so.

The only exception to this is if your application supports Open Sound Control (OSC),
then our panels can be mapped. You will however need to create a map from scratch.
We cover this in the Open Sound Control section.
If your application doesn’t support the Mapper you can create a map which is keyboard
shortcuts only. See the section My application doesn’t support the Tangent Mapper,
panels, or Hub first and then decide if this suits your needs. Once you’ve read that
section you can carry on reading through this guide, but understand you’ll only be able
to map keyboard shortcuts to the controls.
4

Mapper made simple ver1 rev9
Tangent Hub and Tangent Mapper overview
Take a look at the diagram below. You’ll see that the Tangent Mapper, just like an
application, connects to the Tangent Hub background task.

It’s the Hub’s job to act as a communication bridge between an application and the
panels. The Hub also takes the raw inputs from the panels and translates them into
commands the application understands. This implies the panels themselves do not hold
any commands or even know what they are connected to – it’s the Hub that knows all
this. Finally, the Hub detects which application is in the foreground and automatically
applies the appropriate map to the panels.
So where does the Hub get the controls and maps from? Well, when an application
connects to the Tangent Hub, it passes a couple of files to it:
• A controls file which tells the Hub what controls an application has.
• A default map file which is the suggested layout of how the controls are mapped
to a panel.
.
The thing to understand here is that it’s the application that tells the Hub what controls it
has available to be mapped. And it also provides the default map to the Hub.
When the Mapper connects to the Hub it gets access to the applications controls file
and the applications default control map. You can edit the default map and save your
version as a user map. You can have more than one map for each application, and you
use the Mapper to switch between these maps.
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The Mapper does not need to be running all the time. Only use it when you want to
remap the controls on your panel. The Tangent Hub will always be running in the
background.
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Let’s get some basic terms and concepts out of the way first
It’s important that you understand the following terms and concepts as they form the
basis of how the Mapper works. We’re going to be using these terms a lot throughout
the rest of this guide.
So let’s start with an overview of a map file - see the diagram below. Imagine a simple
panel with only 3 knobs, 3 buttons, and 3 trackerballs.

5.1 Map
A map is a file that describes how the controls in an application are laid out on a
panel.
The controls within a map are arranged into modes and banks. The map that is
loaded when an application is run is the last one that was used by the application.
Most applications provide a default map which you can use as the starting point for
your own custom map.
5.2 Mode
A mode is a way of grouping controls together that all apply to a certain way of
working or used for a certain process.
For example, you might have a mode for primary colour correction, a mode for
secondary colour correction, and a mode for noise reduction. All the controls for
each mode would be grouped together in a mode of the same name. As you switch
between these modes in the application, the controls on the panel automatically
change to be ones relevant for that mode.
In our example map file we have three modes: A, B, and C. But you can have as
many modes as you or the application needs. Of course, the modes will have
names appropriate to the application, we are just using A, B and C as simple
7
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names. We’ve only filled in controls for mode A for clarity, but modes B and C
would also have their own controls arranged in banks appropriate to that mode.
The modes are normally defined by your application so you won’t need to worry
about creating them. However, you can create your own modes: a good example of
this would be creating a “simple” mode, which only contains the controls you
regularly use from the application defined modes. The thing to note here is that the
application does not know about your mode, so selecting your mode will not trigger
the application to change to any of its modes.
You use the goto mode, next mode, and previous mode function assigned to a
button to select a mode from the panel. For modes defined by the application you’ll
most probably also be able to select them from the application’s user interface.
Some applications do not make use of modes at all, in which case there will just be
the single default mode.
5.3 Bank
In our imaginary panel we only have 3 knobs. Let’s say that our application has 12
controls that all need a knob. But you only have 3 knobs so how do we get another
9 knobs? Well, you can add another bank of knobs. Think of a bank as another
page or layer of controls you can switch to. Switching banks remaps what the
knobs do. As you can see in our example there are 4 knob banks which gives us
the total of 12 knobs we need.
Buttons and trackerballs can also have banks, and in our example we have 3
button banks and 2 trackerball banks.
By default there is at least one bank – you need somewhere to store your controls which you can fill up, and when you run out, you use the Mapper to add another
bank. Each bank does not have to be full, you can add a bank whenever you want;
in fact this is quite a good way of grouping similar controls together.
You can have as many banks as you want.
You use the goto bank, next bank, and previous bank function assigned to
buttons to step through the banks.
5.4 Standard and alternate mapping
Each control, be it a button, knob, or a trackerball, can have a standard and
alternate mapping. The easiest way to think of this is like holding down the shift
key on your keyboard to get another symbol. In this case, you hold down the
Select ALTernative Function button on the panel in order to access an alternative
function that has been mapped to a control. The Select ALTernative Function
can be mapped to any button on the panel and makes that button act just like the
shift key on your keyboard. You can also set a double press of the button to lock
the alternative function on, just like shift lock does on your keyboard - see the User
Preferences menu section.
A good example of why you would want to do this is where you have
complimentary functions like copy and paste assigned to a button. Paste could be
the standard mapping and copy could be the alternate mapping.
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Another good example of its use is where the standard mapping for a knob would
be a coarse sensitivity, and the alternative would be fine sensitivity. In this way you
can quickly jump to a rough value and then hold down the Select ALTernative
Function button to fine tune the value.
Buttons, knobs, and trackerballs can all have alternates assigned to them.
5.5 Auto-select Application
The tangent Hub detects which application is in the foreground and automatically
applies the map for that application to the panels. You can disable this function, but
then you’ll have to manually switch between applications yourself using the
Mapper.
5.6 Button
You can program the buttons to do anything that your application allows. You can
even assign keyboard shortcuts to them. Some buttons have legends on them to
help identify them, but you can still choose what you want them to do.
The only buttons that are different and cannot be programmed are the resets for
the trackerballs and knobs. See the Trackerball and Knob sections below.
5.7 Knob
You can program the knobs to do anything that your application allows. You can
even assign keyboard shortcuts to them, triggering a different keyboard shortcut
depending on the direction of rotation.
The only thing to note with a knob is that if you press down lightly on a knob it will
reset its value. You cannot remap the reset button – it is reserved as a reset only.
5.8 Trackerball
A trackerball is made up of two things: a ball, and a ring or dial. The ring and dial
are essentially the same thing, and what you have depends on what panel you’re
using. We’re just going to refer to ring from now on, but assume we mean dial too.
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The ball and ring each have their own reset:
This resets the trackerball.
This resets the ring.
You cannot remap the resets buttons – they are reserved as resets only. The only
exception to this is when the trackerball is remapped as a mouse when the reset
buttons become left and right mouse buttons.
You can program the ball and ring to do anything that your application allows. You
can even assign keyboard shortcuts to them, triggering a different keyboard
shortcut depending on the direction of rotation.
With the ball it’s possible to assign a different function to each axis.

10

Mapper made simple ver1 rev9
Before you do anything make sure that…
Before you start check the following:
1) You must make sure your panel is plugged in.
2) The application you want to create a map for is running and in the
foreground.
3) Check your application supports the Tangent Mapper.
4) Check your application has been configured to use our panels.
The Mapper will not show anything unless an application is running and connected to
the hub – remember that the Mapper gets the list of controls available from the
application.
You also need to have a panel plugged in so the Mapper knows what it’s trying to map
the controls to.
When you open the Mapper it will show that last active map used for the application. If
it’s your first time running the Mapper this is most likely to be the default map supplied
by your application.
If you haven’t got a panel connected or there’s no application running you will see this:

Having got the Mapper running and showing a map, let’s take a look at the Mapper
window.
11
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The Mapper window
Let’s take a look at what you see in the Mapper window.

7.1 Title bar
The title bar of the window tells you what application is currently selected and what
map is currently being used.
7.2 Mode tabs
These are the top row of tabs across the window and show you what modes have
been defined. As you click on the tabs you’ll see that what is mapped to the panel
changes.
The current mode you’re about to edit in the Mapper has its name highlighted in the
tab.
The current mode the application is currently in is indicated by a white dot next to
the name.
You can set the behaviour of the Mapper to follow / not follow the current mode of
the application you are mapping. See the User Preferences menu section.
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7.3 Panel tabs
If you have multiple panels connected there will be a tab for each panel. In the
above example there is a full set of Element panels connected so there are 4 tabs.
If you only have a Ripple or Wave2 connected there will only be one tab.
Where you have multiple panels connected you click on the tab to select that panel
for mapping.
7.4 Standard / Alternate mapping button
To quickly see what controls on the panel have alternate mappings assigned to
them you can click this button. This switches the view between standard and
alternate.
It’s important that this button is set to the correct view if you’re going to right click
on a control to map it. We’ll cover this a bit later, but for now remember that this
button will affect how a control is mapped.
7.5 Bank editing and selection button
If you left click on the arrow you can step through the banks. In our example above
there only one bank and it’s for trackerballs only as the TK panel has only
trackerballs on it.
If you right click on the arrow you can add and remove banks.
Let’s now go on to look at mapping a control.
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Mapping a control
8.1 Before you do anything check the following four things:
1) Make sure you have the correct mode tab selected.
A common mistake is to have the wrong mode selected and so
your control doesn’t appear where you expect it to.
2) Make sure you have the correct panel tab selected.
This only really applies if you have more than one panel connected;
a set of Elements for example.
3) Make sure you are in the correct bank.
This applies if there is more than one bank of controls. A common
mistake is to have the wrong bank selected and so the control does
not appear where you expect it to.
4) Make sure the standard / alternate button is set correctly.
This only really matters if you’re going to right click on a control to
map it.
8.2 Hovering over a control
When you hover the mouse over a control or its label in the Mapper will highlight it.
This is useful when you’re trying to figure out which label belongs to which control.
There’s only a limited amount of space in the Mapper window to display all the
labels so they’re not always beside or immediately next to the control.
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8.3 Left click or right click to map a control?
You can map a control by left or right clicking on it, or its label.
8.3.1 Left clicking
Opens a control mapping window which gives you access to all the mapping
options, including standard and alternate.
8.3.2 Right clicking
Just opens a pop-up menu of things you can assign to that control. It either
assigns it to the standard or alternate mapping depending on what the
standard / alternate button is set to. If it’s set to standard then it’s going to be
mapped to the standing mapping, otherwise it’ll be mapped to the alternate
mapping. The control mapping window will open once you’ve mapped a
control with the right click just in case you want to go on and make further
changes.
Right clicking on a button or knob is fairly straight forward, however with a
trackerball it depends where you click. You will either map the entire
trackerball or just one of its axis. We’ll cover this in the control mapping
window section of this guide.
8.4 The control mapping window
What the control mapping window shows depends on if it’s a button, knob, or
tracker ball you’re trying to map. We’ll now take a look at each one.
8.4.1

Button mapping options

Mappings Apply To
We’re going to cover this in its own section later on, but for now make a
note that we can apply the mapping we’re about to make to more than
just the current bank and mode.
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Standard Mapping
As you might expect, what is under this heading is what you’ll get if you
press the button on the panel. If nothing is currently mapped to the button
it’ll say No Mapping.
Alternate Mapping
This is what you’ll get if you hold down the Select ALTernative Function
button at the same time as you press this button on the panel. If nothing is
currently mapped to the button it’ll say No Mapping.
Display Label
By default this will be filled in with the application’s name for the control
you have mapped. You can create your own custom label by clicking in
this text box and typing in your own label. The label is what appears on
the panel’s display.
Link standard and alternate mapping
Clicking on this will make the alternate mapping be the same as the
standard mapping. This is just a quick way of filling in both the standard
and alternate mapping with the same thing.
Menu Step Direction (menu type of control only)
In this example, the alternate mapping has a menu type of control
assigned to the button. Pressing the button on the panel would step
though the menu options. You can change the direction it would step
through the menu by selecting the direction here.
8.4.2

Knob mapping options
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Mappings Apply To
We’re going to cover this in its own section later on, but for now make a
note that we can apply the mapping we’re about to make to more than
just the current bank and mode.
Standard Mapping
As you might expect what is under this heading is what you’ll get if you
move the knob on the panel. If nothing is currently mapped to the knob it’ll
say No Mapping.
Alternate Mapping
This is what you’ll get if you hold down the Select ALTernative Function
button at the same time as you move this knob on the panel. If nothing is
currently mapped to the knob it’ll say No Mapping.
Display Label
By default this will be filled in with the application’s name for the control
you have mapped. You can create your own custom label by clicking in
this text box and typing in your own label. The label is what appears on
the panel’s display.
Link standard and alternate mapping
Clicking on this will make the alternate mapping be the same as the
Standard mapping. This is just a quick way of filling in both the Standard
and alternate mapping with the same thing.
Display Type
On the panel’s display, the knob is normally labelled with the Display Text
mentioned above. However, when you move the knob the panel’s display
can be set to show the value of the control as it changes. Different
formats are available, these are:
• Blank – no value is displayed.
• Number – the actual numerical value of the control is displayed.
• Bar – the value is displayed as a bar graph.
• Percentage – the value is displayed as a percentage.
Note: If the application does not report the value to the Tangent Hub you
will not see it displayed on the panel regardless what this option is set to.
If you are mapping a menu to the knob then you’ll not see this option.
Knob Sensitivity
As you would expect this sets the sensitivity of a control. But, and this is
very important, it depends on what the Global tick box is set to.
By default Global is ticked, and this means the sensitivity is taken from
the File > Control Map Settings menu.
If you untick Global, then you can set the sensitivity for just the control
you have mapped to this knob.
You can find out more in the Control Sensitivity section of this guide.
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Reverse Knob Direction
This is pretty self-explanatory - if you want the knob to work the other way
around then tick this box.
8.4.3 Trackerball mapping options
Where you click on the trackerball in the Mapper determines what you will see
in the mapping options. This is because a trackerball is made up of three axis:
ball left/right, ball up/down, and ring/dial.
Combined mapping
You can either elect to map the entire trackerball with a combined
mapping (mapping both the ball and ring), or map each axis of the ball,
and the ring individually. You’ll note when you go to map a trackerball one
of the sub menus is actually called combined. An example of a combined
mapping would be something like where positon is mapped to the ball, and
zoom is mapped to the ring. Just think of combined mapping as where the
application has already grouped three functions together that naturally map
to a trackerball.
Clicking in the area of the trackerball will bring up the combined mapping
options. Clicking on each of the labels will bring up the mapping options for
that axis.

The following two images show the difference between the combined and
individual axis mapping windows.
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Combined ball mapping options:

Individual axis mapping options:
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Mappings Apply To
We’re going to cover this in its own section later on, but for now make a
note that we can apply the mapping we’re about to make to more than
just the current bank and mode.
Standard Mapping
As you might expect what is under this heading is what you’ll get if you
move the trackerball on the panel. If nothing is currently mapped to the
trackerball it’ll say No Mapping.
Alternate Mapping
This is what you’ll get if you hold down the Select ALTernative Function
button at the same time as you move this trackerball on the panel. If
nothing is currently mapped to the trackerball it’ll say No Mapping.
Display Label (individual axis only)
By default this will be filled in with the application’s name for the control
you have mapped. You can create your own custom label by clicking in
this text box and typing in your own label. The label is what appears on
the panel’s display.
Link Standard and alternate mapping
Clicking on this will make the alternate mapping be the same as the
Standard mapping. This is just a quick way of filling in both the Standard
and alternate mapping with the same thing.
Display Type (individual axis only)
On the panel’s display, the trackerball is normally labelled with the Display
Text mentioned above. However, when you move the trackerball the
panel’s display can be set to show the value of the control as it changes
in different formats. These are:
• Blank – no value is displayed.
• Number – the actual numerical value of the control is displayed.
• Bar – the value is displayed as a bar graph.
• Percentage – the value is displayed as a percentage.
Note: If the application does not report the value to the Tangent Hub you
will not see it displayed on the panel regardless what this option is set to.
If you are mapping a menu to the trackerball then you’ll not see this
option.
Ring / Trackerball Sensitivity
As you would expect this sets the sensitivity of a control. But, and this is
very important, it depends on what the Global tick box is set to.
By default Global is ticked, and this means the sensitivity is taken from
the File > Control Map Settings menu.
If you untick Global, then you can set the sensitivity for just the control
you have mapped to this knob.
You can find out more in the Control Sensitivity section of this guide.
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Reverse Ball / Ring Direction
This is pretty self-explanatory - if you want the control to work the other
way around then tick this box.
If you want to change the direction of the axis of the ball you need to click
on the label in the Mapper in order to call up individual axis mapping
options.
8.5 Mappings apply to option

When you go to map a knob, button, or trackerball you will be given the option as
to how you want the mappings applied.
Clicking on the Mappings apply to menu gives you the following options:
• Current bank in the current mode.
• All banks in all modes.
• Current bank in all modes.
• All banks in current mode (only available if there’s more than one bank).
Let’s now look at what each option means. To help illustrate what happens imagine
we have a simple panel with just 3 buttons, and three modes; A, B and C. Mode A
has 2 button banks, mode B has 4 button banks, and mode C has 3 button banks.
Now imagine we want to map the third button in bank 2 of mode A. This all sounds
a bit complicated so we’ll draw what we mean – the button in question is circled in
red:

Now, for each of the possible Mappings apply to settings we’ll show the result.
The buttons that end up being mapped are circled in green.
Note: If you choose anything other than “current bank in the
current mode” you need to be aware you’ll be potentially
overwriting what was ever mapped to the same control in other
modes and banks.
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8.5.1

Current bank in the current mode

8.5.2

All banks in all modes

8.5.3

Current bank in all modes

8.5.4

All banks in current mode
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8.6 Assigning keyboard shortcuts to a button
You can assign a keyboard shortcut to a button.
Start by right clicking on the button and assigning Keyboard Shortcut to it.

A keyboard shortcut is limited to a single key to which you can apply the usual
modifiers such as CTRL and SHIFT. It’s not possible to do macros.
In our example we have assigned the following to the button:
• ALT + J
Here’s the steps to do this:
1. Click in the text box under Keypress Settings.
2. Type ‘J’
3. Press the Alt button in the window.
Repeat
This determines how many times the key press is sent out per button press.
Only the key press is sent out each time with the modifier being held “on”
throughout the entire number of Repeat presses.
Reset
If you make a mistake and want to clear the selected key and its modifiers,
press the Reset button.
As with all controls you can customise the label for this control by typing in your
own text into the Display Label text entry box.
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8.7 Assigning keyboard shortcuts to a knob or trackerball
You can assign a keyboard shortcut to a knob or trackerball, with the direction of
rotation triggering a different shortcut. The process is the same for either a knob or
a trackerball axis, but we’ll take a look at assign a knob in this example.
Start by right clicking on the knob and assigning Keyboard Shortcut to it.

A keyboard shortcut is limited to a single key to which you can apply the usual
modifiers such as CTRL and SHIFT. It’s not possible to do macros.
In our example we have assigned the following:
• Rotate to the right = SHIFT + J
• Rotate to the left = CTRL + K
Here’s the steps to do this:
4. Click in the text box for rotate right.
5. Type ‘J’
6. Press the Shift button in the window.
7. Click in the text box for rotate left.
8. Type ‘K’
9. Press the Ctrl button in the window.
Repeat
This determines how many times the key press is sent out per step the knob is
rotated. How far you need to rotate the knob between steps is determined by
the setting of the knob sensitivity. Only the key press is sent out each time with
the modifier being held “on” throughout the entire number of Repeat presses.
Reset
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If you make a mistake and want to clear the selected key and its modifiers,
press the Reset button.
As with all controls you can customise the label for this control by typing in your
own text into the Display Label text entry box.
8.8 Mouse emulation – turning a trackerball into a mouse
You can turn a trackerball into a mouse:
- The ball will move the cursor around.
- The ring acts as a scroll.
- The reset buttons act as the mouse buttons.
There’s two ways you can access mouse emulation:
•

Assigned like a normal control
You can have the trackerball always assigned as mouse, in much the same
way any other control is assigned to it.

Or…
•

Toggled on and off using a button
You can have the trackerball turn into a mouse by pressing a button to
toggle the mouse assignment on and off.

8.8.1 Assigned like a normal control
Right click on the trackerball and select Mouse Emulation from the list of
controls you can assign to the trackerball.

Mouse speed
Sets how far the mouse scroll moves for every increment of movement
the ring makes.
Scroll speed
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Sets how far the mouse moves across the screen for every increment of
movement the ring makes.
Reverse scroll direction
Ticking this box changes the “direction” of the scroll emulation when you
rotate the ring.
8.8.2 Toggled on and off using a button
First decide which button you want to toggle the mouse on and off with. Then
right click on the button and select Toggle Mouse Emulation from the list of
controls you can assign to the button. Note you are not mapping the
trackerball, you are actually mapping a button which, when you press it, will
toggle the mouse emulation on and off for a chosen trackerball. In the example
below we’ve chosen to map the ‘B’ button to do this.
The button you choose must be on a panel that has a trackerball
on it. For example you can’t use a button on the Element-Bt panel.

“Mouse Emulation On:”
This selects which trackerball will be turned into a mouse when the button
is pressed. For example, on the Element-Tk panel the choice will be left,
middle, or right. On the Mf panel there’s only one choice possible which is
as there’s only one trackerball.
Mouse speed
Sets how far the mouse scroll moves for every increment of movement
the ring makes.
Scroll speed
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Sets how far the mouse moves across the screen for every increment of
movement the ball makes.
Reverse scroll direction
Ticking this box changes the “direction” of the scroll emulation when you
rotate the ring.
8.9 I can’t find the control I want in the Mapper
If you remember, back in the Tangent Hub and Tangent Mapper overview
section of this guide we said it’s the application that tells the Hub what controls it
has available to be mapped. So if the Mapper isn’t showing a control it’ll be
because the application hasn’t told the Mapper that the control is available to be
mapped. There’s nothing Tangent can do to make the control magically appear, the
only thing you can do is to contact the applications maker and ask them to add it
the list of controls they send to the Tangent Hub.
The only other possibility is that the control is in fact something that is normally
accessed via a keyboard shortcut. In this case just choose to map the keyboard
shortcut to the control on the panel.
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Banks – adding / deleting / selecting them
We introduced the concept of banks in the Let’s get some basic terms and concepts
out of the way first section of this guide. If you haven’t read this section then do it now.
Hopefully you understand that a bank is just another layer of controls you can step to,
where you have more controls in your application than you have physical controls on
the panel.
9.1 Before you do anything check the following two things:
1) Make sure you have the correct mode tab selected.
A common mistake is to have the wrong mode selected and so
your control doesn’t appear where you expect it to.
2) Make sure you have the correct panel tab selected.
This only really applies if you have more than one panel connected.
9.2 Knobs, buttons, and trackerballs can all be banked
Knobs, buttons, and trackerballs each have their own banks which operate
independently of each other. The principle is the same: you create, edit, delete,
and control them in the same way.
Some controls can’t be banked, we’ll cover these at the end of this section.
9.3 Controls in the Mapper that are associated with banks
Let’s look at an example using the Element-Kb panel, but remember the same
principles apply to buttons and trackerballs too.
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There’s a couple of things to note in our example before we go any further: the Bank
editor and selection button, and the B button which has Next Knob Bank assigned to
it. The next couple of sections discuss what these do.
9.4 Bank editor and selection button
You find this button next to groups of controls that can be banked together. It’s not
a button on the panel, it’s a menu button on the Mapper display that allows you to
select which bank you’re editing in the Mapper, and add / remove banks. Note it
only operates on the group of controls it’s associated with.
In our example with the Kb panel we have 2 banks. Remember there will always be
at least 1 bank.
You can either left click or right click on this button to do different things. We’ll now
take a look at what the options are.
9.4.1 Left click
If you left click on the Bank editor and selection button you step through all the
banks that have been created.

>
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9.4.2 Right click
Right clicking on the Bank editor and selection button brings up a menu with
the following options:

Add Bank At End
This adds an empty bank at the end of the list of current banks.
When you add a bank, if any of the controls in other banks have been
mapped to be all banks then these will automatically be copied into the
new bank. See the “Mappings apply to” option section of this guide.
One final thing to note when you Add Bank At End; the Mapper will not
update to show that bank, you need to left click the Bank editor and
selection button to go to that bank.
Insert Bank Before Current
Inserts a bank before the current bank you’re on in the Mapper.
When you insert a bank, if any of the controls in other banks have been
mapped to be all banks then these will automatically be copied into the
new bank. See the “Mappings apply to” option section of this guide.
Remove Current Bank
Deletes the current bank you’re on in the Mapper.
Clear Current Bank
Clears all mapping within the current bank you’re on in the Mapper.
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9.5 Moving between banks using your panel – Previous / next buttons
Having created some banks you of course need to move between them on the
actual control panel. Let’s take a look again at the Element-Kb example we started
with. Next to the Bank editing and selection button you can see it says “Knob Bank
1 of 2” which means there are two banks you can switch between.

You’ll notice the B button has Next Knob Bank assigned to it (it’s highlighted in
blue in the image above). If you press the B button on the panel, you’d step forward
to the next bank.

>
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That’s great, but it means you’d have to keep pressing the Next Knob Bank button
until you got back to the beginning if you wanted to go back to bank 1. This might
be ok if you only have a couple of banks, but what if you have 10 banks? It’d be a
little tedious to keep stepping forward until you got back to the bank you wanted!
There is a Previous Knob Bank function you can assign to a button which lets you
step in the other direction. Now you can go backwards and forward through all the
banks.
In the example below you can see we have assigned Next Knob Bank to the
standard mapping for the button, and Previous Knob Bank for the alternate
mapping for the button. You’ll notice that the A button has Select ALTernative
Function assigned to it. Putting it all together what we get is:
• Pressing just B steps you to the next bank.
• Pressing and holding A whilst you press B steps you to the previous bank.

Note that A and B buttons can be mapped to do any function, and the next and
previous knob banks functions can be mapped to any button on your panel. We’ve
just used A and B in our example for convenience.
9.6 Go to a specific bank using your panel – Goto Bank button
We’ve looked at stepping to the previous and next bank, but there’s also a way to
go to a specific bank number. Sticking with our example of the knobs of the Kb
panel, you just assign to the button to be Goto Knob Bank. Of course there a
similar function for button and trackerball banks.
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The Target Bank Number is where you set which bank will be selected when you
press the button.
9.7 What controls have banks on the various Tangent panels
In the following pictures of the various Tangent panels the controls which are part
of a bank are shown grouped in red.
9.7.1

Ripple

The A and B buttons aren’t part of any bank, but the three trackerballs are.
Even though the buttons have A and B on them, they can be used for anything
you want.
9.7.2

Wave / Wave2

Note only the 9 knobs and 9 buttons around the displays are part of a bank.
Even though some buttons have printed labels on them, they can be used for
anything.
9.7.3

Element

Note that the A and B buttons, and transport buttons are not part of any bank.
Even though some buttons have printed labels on them, they can be used for
anything.
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9.7.4

Arc

On the Navigation panel there are three groups of buttons that are treated as
three independent button banks. They are referred to as Left, Middle, and
Right bank.
The two buttons above each trackerball are reserved as resets for the ball and
ring and aren’t part of any bank.
Any other buttons are not part of a bank.
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9.8 Independent panel banks – changing bank on just one panel and not all
panels
If you have more than one panel connected - you have the Element panels for
example - then pressing previous / next bank buttons can either step through
banks on just that panel, or across all panels.
Let’s look at the example of the Element-Mf and Element-Bt panels being used
together. Each has a group of 12 buttons which are part of banks. The buttons
grouped with banks are highlighted in red in the next two images. Note the Next
Button Bank function has been assigned to the ‘B’ button on both panels.
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The result of pressing the ‘B’ button will do one of two things based on the Mapper
File > Control Map Settings… window. Let’s take a look at that window now.

As you can see under General Settings there is a tick box labelled Independent
panel banks.
9.8.1 Independent panel banks - ticked
With this box ticked, pressing the ‘B’ button on the Mf panel would only change
the bank for the buttons on the Mf panel. Press the ‘B’ button on the Bt panel
would only change the bank for the buttons on the Bt panel.
9.8.2 Independent panel banks - unticked
With this box unticked, pressing the ‘B’ button on the Mf or the Bt panel would
change the bank for the buttons on both the Mf and Bt panel.
Let’s say the Mf panel had 4 button banks and the BT on had 2. As you
stepped through the button banks everything would work as expected for the
first two steps. But when the Mf steps to the third bank you’ll see the Bt display
go blank, and the same for the fourth step, until we go back round to the first
bank when everything is back in step again. This is because the BT has no
third or fourth bank, so it has nothing to display for these. Hopefully the table
below explains this better
Step to Bank 1
Step to Bank 2
Step to Bank 3

Bt has 2 banks
Bt Bank 1 is displayed
Bt Bank 2 is displayed
Display is blank

Mf has 4 banks
Mf Bank 1 is displayed
Mf Bank 2 is displayed
Mf Bank 3 is displayed
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Step to Bank 4

Display is blank

Mf Bank 4 is displayed

If you wanted to map something to banks 3 and 4 on the Bt panel, you would
will need to go into the Mapper and actually add these banks. Until you do this
they are just two empty banks you can’t access as they do not exist
Just to finish up this section, in case you haven’t realised, tick box for Independent
panel banks applies to knobs as well as trackerballs. Remember these each have
their own set of banks which work independently from each other.
9.9 You cannot gang button, knob, and trackerball banks together
There is no function to step through all button, knob, and trackerball banks together
– by that we mean ganged together. Each control type has its own independent
bank system.
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Modes – adding / deleting / selecting them
Let’s quickly recap what learnt about modes at the start of this guide where we
discussed terms used. Within an application there may be different modes of working,
for example you might have a mode for primary colour correction, a mode for secondary
colour correction, and a mode for noise reduction. As you switch modes in the
application, the controls on the panel automatically change to reflect those related to
that mode. Normally an application will have defined the modes, but you can add your
own custom modes.
The modes available in an application are shown across the top of the Mapper window
in tabs. Both application defined and custom modes are shown.

It should be noted that some applications do not make use of modes so there will only
be one tab.
The highlighted tab shows which mode is currently selected for editing in the Mapper.
The mode that your application is currently in has a little white marker on the left of the
tab.

A common mistake is not having the right mode selected in the Mapper when you go to
edit a control.
10.1 Difference between application defined modes and your own custom modes
Before we go on to talk about editing modes and defining your own we need to
explain the difference between modes defined by an application and your own
custom modes.
10.1.1 You can’t delete modes defined by an application
Modes defined by an application can’t be deleted. However, you can
customise the controls in them, and save the map out as your own custom
map. The modes are selected by using your application user interface, or by
pressing a button on the panel that been assigned to change the mode.
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10.1.2 Custom modes you add don’t automatically get selected by the
application
If you add your own custom mode, your application will not know of its
existence, so there is no way for an application to automatically change to
your custom mode. You have to select the mode manually by assigning a
button on the panel to go to that mode.
10.2 Adding and deleting modes
To add or delete a mode you need to go to the Mapper File > Edit Modes… menu.
This will open the Mode Configuration window.

10.2.1 Add a mode
Clicking on the ‘+’ button will add a mode. You can then type in the name of
the mode. Click Apply when you’re done.
10.2.2 Delete selected mode
First highlight the mode you want to delete. Then click the ‘-‘ button. Note you
can’t delete a mode with a padlock icon next to it as it’s an application defined
mode. Click Apply when you’re done.
Any mode with a padlock icon next to it can’t be deleted. This is a mode
defined by an application.
10.2.3 Change the position of a mode in the mode tabs in the Mapper
If you add a mode, it will appear in the mode tabs across the top of the Mapper
window after any application defined modes. You can change the order the
custom modes appear in the tab by using the up and down arrow buttons.
Note custom modes will always appear after application defined modes, you
cannot position them before within the application defined modes.
39

Mapper made simple ver1 rev9
Click Apply when you’re done.
Once you’ve added a new mode you can add controls to back in the main Mapper
window. Just remember to select it’s tab in the mode tabs!
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10.3 Moving between modes using your panel – Previous / next buttons

Take a look at the above example. The highlighted B button has Next Mode
assigned to it. Pressing this button on the actual panel will step you through the
modes in the order they appear in the mode tabs.
If you had a lot of modes this would be pretty tedious to repeatedly step through
them all to get back to the mode you want. So we’ve assigned the alternate
mapping to be Previous Mode. You’ll notice that the A button has Select
ALTernative Function assigned to it. Putting it all together what we get is:
• Pressing just B steps you to the next mode.
• Pressing and holding A whilst you press B steps you to the previous mode.
Note that A and B buttons can be mapped to do any function, and the next and
previous mode functions can be mapped to any button on your panel. We’ve just
used A and B in our example for convenience.
Make sure you have the “Mappings Apply To” set correctly
A common mistake is to have the wrong “Mappings Apply To”
selected. In our example we have it set to All Modes meaning that this
button will do the same thing in all modes. If you don’t set it to be in all
modes then when you step to the next mode, the button will no longer
be there and you won’t be able to continue to step through the modes
using this button.
In a similar way, make sure you have taken into consideration what
banks you have for buttons.
The most suitable choices we suspect you want are:
• All banks in all modes.
• Current bank in all modes.
If you’re unsure what’s best then see “Mappings apply to” in the
Mapping a control section of this guide.
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10.4 Go to a specific mode using your panel – Goto Mode button
We’ve looked at stepping to the previous and next mode, but there’s also a way to
go to a specific mode. To do this we assign the Goto Mode function to a button.

The Target Mode is where you set which mode will be selected when you press
the button.
Again, make sure you have the appropriate “Mappings Apply To” selected.
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Control Sensitivity
If you want the trackerballs or the knobs to be more or less sensitive (move their control
more or less for a given movement) then go to the Mapper and open the File > Control
Map Settings… menu. You should now get a pop-up window like this:

Set the sensitivity to suit how you want the control to respond:
• fine means you have to move the control further to get a change.
• coarse means you will need to move the control less to get a change.
These settings apply globally to all controls of that type on the panel – every knob or
trackerball control will have the same sensitivities. If you wish to change the sensitivity
for just a certain control within your application then you can do this by unticking Global
setting for that control - see the Knob mapping options and Trackerball mapping
options sections of this guide.
As you can see, there are global sensitivities for both standard and alternate mappings.
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Switching between maps
Having made your own maps for an application you’re going to want to switch between
them. First make sure your application is running. Then go to Mapper File > Manage
Control Maps… menu. You should now see the Map Management window.

Make sure your application is selected in the Applications area. Then choose the map
you want to use from the Control Maps area. Finally click the Select button.
You’ll note that there is a Default Controls which has a padlock icon next to it. This is
the default control map supplied with your application. You can edit this and save your
changes out under a new name, but you cannot overwrite or delete it.
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Make a new control map
This assumes you are making a map for an application that supports
the Mapper. If you are making a map for an application that is not
supported see the My application doesn’t support the Tangent
Mapper, panels, or Hub section of this guide.
The easiest way to do this is to start with an existing map. For example, use the default
map supplied by your application. Make the changes to this and save this out under a
new map name.
However, if you insist on starting from scratch and creating a whole new map, then
here’s how you get started.
Make sure your panel is plugged in.
Make sure your application is running and in the foreground.
Run the Mapper and go to the Mapper File > New Control Map… menu.
You should now see the following window.

Select an application:
Select your application from the list that pops up when you click on this menu.
If your application isn’t in the list ten it’ll be for the following reasons:
• The application isn’t running.
• You haven’t configured your application to use the Tangent panels.
• The application is running but doesn’t support the Tangent panels. In this
case are you trying to do a keyboard shortcut only map for the application?
If you are then see the My application doesn’t support the Tangent
Mapper, panels, or Hub section of this guide.
Do not select the Add a New Application… option! This is only really
used when you’re creating a keyboard shortcut map for an application
that doesn’t support the Tangent panels.
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Finally click Finish.
You should now be back in the main Mapper window with an empty map. The modes
the application has defined will be there in the modes tab.
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Delete a control map
Go to Mapper File > Manage Control Maps… menu. You should now see the Map
Management window.

Make sure your application is selected in the Applications area. Then choose the map
you want to delete from the Control Maps area. Finally click the Delete button.
14.1 You can’t delete the current map you’re using.
You’ll need to select another map first.
14.2 You can’t delete the default map.
The default map will have a padlock icon next to it. You can’t delete this as it’s the
default map supplied by your application.
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Backing up and restoring your maps – Export / Import
First make sure your application is running. Then go to Mapper File > Manage Control
Maps… menu. You should now see the Map Management window.

15.1 Backup (Export)
Make sure your application is selected in the Applications area. Then choose the
map you want to use from the Control Maps area. Finally click the Export button.
You’ll be prompted to choose a place where to save the file to.
15.2 Restore (Import)
Make sure your application is selected in the Applications area. Then click the
Import button. You’ll be prompted to navigate to where the file is you want to
import.
You can also use the import / export function to take your maps with you if you need to
go to another facility to work.
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Ripple specific things
16.1 Element-Tk Emulation
The Ripple has the same number of controls as the Tk panel, this means you can
use it with any application that supports or has a map for the Tk. To put the Ripple
into Tk emulation mode, go to the Mapper File > Panel Configuration… menu.
Tick the box Ripple emaulates an Element-Tk option.

16.2 Virtual Head-Up-Display (HUD) for Ripple
The Tangent Hub has a virtual Head-Up-Display (HUD) for the Ripple. As the
Ripple has no display, the HUD pops up on your computer monitor as a reminder
of what the controls on Ripple are mapped to, and it’s triggered by a mode change
or a control move. You can configure the HUD by going to the Mapper File > Panel
Configuration… menu.
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Element specific things
Each panel has a display. The display is used to label what the controls do.
17.1 Bt, Kb, and Mf left display
In the case of the buttons and knobs on the Kb and Bt panel, the display is split into
a grid of 12 cells, with each cell representing a control. The cell position of the
display matches the control position on the panel. The same applies to the group of
12 buttons on the Mf panel.

17.2 Tk display
The top line of the display will tell you what mode and bank you’re in. The rest of
the display is split into a grid of 9 cells that label what each axis of the trackerball is
assigned to.

17.3 Mf right display
The top area of the display is given over to the application for it to use for whatever
it wants. What appears here isn’t controlled by Tangent. The rest of the display is
split into a grid of 3 cells that label what each axis of the trackerball is assigned to.
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Arc specific things
18.1 Every control has its own display
Every control on Arc has its own display which is used to label what the control has
assigned to it.

18.2 Main display at rear of each panel
The display at the back of the panel is split into three lines. The top two lines of the
display is given over to the application for it to use for whatever it wants. What
appears here isn’t controlled by Tangent. The bottom line with a grey background
displays band and mode information.

18.3 Trackerball reset buttons and displays
The two buttons above each trackerball are reserved as resets. Their displays label
what the ring and ball are assigned to.
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Element-Vs app specific things
The Element-Vs app emulates the Element panels. You can use the Mapper with the
app just as if you had real Element panels. In the Mapper just map the Element panels
and these will appear in the Vs app. This also includes adding multiples of each
Element panel.
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Adding and deleting panels
The Mapper needs to know what panels you have physically connected so it knows it
has to look for them. By default, the Mapper settings already have one of each panel
type added which suits most people’s needs, so it’s unlikely you’ll never need to change
this. It’s ok to have panels added that you don’t actually have connected as the Mapper
only ever shows panels that are really there and available.
The Mapper allows you to add more panels if you physically have more of them. For
example, some applications may come with a default mapping that needs two ElementBt panels. So, if you buy a second Bt panel then you need to tell the Mapper you’ve got
an extra one plugged in. To do this you need to go to the Mapper File > Panel
Configuration… menu. You should see the window below.
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Click on the Edit button to make changes to the panels you have connected. This will
enable the functions as shown below.

20.1 You can’t add or delete panels whilst an application is running
You need to quit any applications that are using the panels before you make any
changes.
20.2 Add a panel
Clicking on the ‘+’ button will pop up a menu from which you can select the panel
type you want to add. Note you can have multiple of each panel type. Click Apply
when you’re done.
20.3 Delete selected panel
First highlight the panel you want to delete. Then click the ‘-‘ button. Click Apply
when you’re done.
20.4 Change the position of a panel in the panel tabs in the Mapper
If you add a panel, it will appear in the panel tabs across the top of the Mapper
window. You can change the order the panel appear in the tab by using the up and
down arrow buttons. Click Apply when you’re done.
20.5 Serial number
This is automatically filled in once a panel is plugged in. Normally you can ignore
this, but you’ll need to know about it, and possibly change this when you have
more than one of a panel, for example two Element-Bt panels. See the Having
more than one of a panel section.
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You can mix different panel types and quantities
If you physically have different Tangent panels, you can plug them all in and add them
to the Mapper. This is most probably more applicable with Elements where it was
always intended that users could have multiples of each panel type. But it’s also useful
if you want to use something like using a Ripple with the Elements instead of a Tk.
Something else to consider is that you can use the Element-Vs app to emulate Element
panels. So, for example, if you have a Ripple only, you can use the Vs app to add
virtual Element panels. This also includes adding multiples of each Element panel.
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Having more than one of the same panel
If you haven’t done so, read the Adding and deleting panels section of this guide first.
Some applications will have default maps that require more than one of a particular
panel. This normally only applies to Element panels as it was always intended that
users could have multiples of each panel type. So for example you may have an
application that requires two Bt panels. You should check with your application what the
recommend number of each panel is.
Let’s stick with our example of needing two Bt panels. Our panels have already been
added to the list of panels we have, and so our Panel Configuration window looks
something like what’s shown below. Note we’ve shown the window when we’ve
selected each instance of the Bt panel.

Things to note initially are:
• The bracketed number after each Bt panel. Here we have:
o Element-Bt (1)
o Element-Bt (2)
The bracketed number is the panel number and is automatically added as soon
as we add more than one of a panel type.
• Each Bt panel has its own unique serial number. This will automatically be filled
in when the panel is connected, but you can also type this in manually. Here we
have:
o Element-Bt (1) serial number 43044058
o Element-Bt (2) serial number 43044059
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In the Mapper, the panel tabs show the two Bt panels, identified by the panel number
which is shown in brackets. So what we have in the Mapper panels tabs looks like this:

So, now we understand the Bt panels have been given a panel number and a serial
number, we look at why this matters. You’ll want to position the Bt panels on your desk
in a position that suits you. And you’re going to want to have the same mapping always
come up on the same panel. You can do this using the combination of the serial number
and panel number, here’s how:
1.
2.
3.
4.
5.

Map the controls to the BT panels 1 and 2 in the Mapper.
Decide where you want physically want the Bt panels on your desk.
Look at the serial number on the back of the panel.
Decide if this is going to be panel 1 or panel 2.
Make sure the panel number in the Panel Configuration window has that serial
number. If it doesn’t edit the serial number.
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Controlling via Open Sound Control (OSC)
OSC messages can be triggered from any control on any panel. You’ll either need to be
modifying an existing map for your application if it has one e.g. the default map that
ships with the app or you’ll need to create a new map for your application - see section
24.1 Creating a new map for unsupported applications. If you haven’t read the
previous sections of this document then do so now before going any further.
23.1 OSC specific controls
When adding an OSC mapping you need to:
• Set OSC Command as the control type.
• Set an OSC Server Port number to send
to.
Messages are always sent to LocalHost.
The same port number will be used for all
OSC Messages in the same map.
• Set the OSC String Identifier which will be
used as the OSC message Address.
• Set the Display Label to be shown on the
panel displays.
• Set the OSC Value Format to be Integer /
Float for Parameters or Integer/ Float /
String for Actions
•
•
•

For parameters only:
Set the Display Type to be shown on the
panel displays.
Optionally, choose to send Absolute
Values rather than Changes.
Set the Min, Max and Step values.

NOTE: As with all mappings, it is recommended that the Standard and Alternate
mappings for encoder controls are set to be the same unless there is good reason not
to. The parameter sensitivities for Std and Alt will then follow the Global settings chosen
in the Mapping Settings (File > Control Map Settings…) by default.
To do this, click the Link icon in the Control Mapping Window:
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23.2 OSC messages sent from the panel to the application
Parameter Change & Reset messages
• By default, increment values are sent when an encoder is moved. This means that a
stream of small positive and negative changes will be sent. If your application
expects absolute values instead then just tick the Use Absolute Values box.
• Parameter OSC messages are sent approx. every 30mS when an encoder is being
turned quickly enough. Less often when turning slowly. The Knob Sensitivity slider
determines how many revolutions of the encoder will reach full range.
• When an encoder changes, positive changes will be sent for a clockwise rotation
and negative for anticlockwise. This behaviour can be reversed by checking the
Reverse Knob Direction box.
• When the reset button associated with any encoder is pressed a value of Zero will
be sent to indicate this when using Increments or the Minimum value will be sent
when using Absolute values.
Action messages
• Action OSC messages are sent when a button is pressed or released.
• On press, a value of 1 is sent for Integer or Float Value Formats and the text On for
String Format.
• On release, a value of 0 is sent for Integer or Float Value Formats and the text Off
for String Format.
23.3 OSC messages sent from the application to the panel
An application can send control messages to the panels which can cause display
values or status text to be shown or control other functions of the panel. The address of
the incoming message will determine whether the message is destined for a particular
control or is a command. This should be useful to display the value of Parameters or the
Menu state for both Actions and Parameters which have multiple discreet states.
NOTE: a random return port will be chosen when the application makes first contact
with the OSC Server so you should interrogate the client socket to determine the return
port number to use
If the OSC Address in the message matches with the OSC Address defined for any of
the controls then the command in the message is directed to that control:
If the OSC Value Format is Integer or Float:
If the control is a Parameter and the Display Type is set to:
• Number then the value will be displayed as received.
• Percentage then the Min and Max values will be used to calculate the
value to display.
• Bar then the Min and Max values will be used to calculate the value to
display in Bar Graph format.
If the control is an Action:
• The string “Off” will be shown for a value of zero
• The string “On” for any non-zero value.
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If the OSC Value Format is String and the string value is:
• RenameControl[“newName”] - The newname string within the brackets will
become the new control name. Sending an empty string will reset the control to
its default name.
• HighlightControl[On] - Highlight this control.
• HighlightControl[Off] – Do not highlight this control.
• IndicateControl[On] - Indicate this control.
• IndicateControl[Off] – Do not indicate this control.
• If the string is none of the above then the string sent will be used as the value.
This is useful for menu style controls.
If the OSC Address in the message is /HubCommand:
If the OSC Value Format is Integer or Float then the message will be ignored
If the OSC Value Format is String and the string value is:
•
•

ModeValue[integer] - The integer value within the brackets is the number of
the mode to select. Numbering starts at 1 for the first defined mode and so on.
DisplayText[“text1”,“text2”,”text3”] – The text strings sent are used to write
to the 3 user defined display lines e.g. on the element-Mf panel.
This command can take up to three quoted strings separated by commas. To
leave a line unchanged, use an empty string or no quoted value at all (i.e. just a
comma). If a quoted value is immediately prefixed by an asterisk then that
means double height.
As an example, to set the second line of the display to double height, leaving
the first line as it was send this:
DisplayText[,*”Big Text”]
An empty first field, an asterisk prefixed second line and the third is irrelevant
so would be ignored anyway due to the double height instruction.
To blank the display you would send a single space for each line e.g.:
DisplayText[“ “, “ “, “ “]
An empty string never has any effect, a blank must have some whitespace
characters.
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My application doesn’t support the Tangent Mapper, panels, or Hub
If your application doesn’t support the Tangent Mapper or the Tangent panels, you can
still use them with your application by mapping keyboard shortcuts or sending Open
Sound Control (OSC) messages.
Let’s just confirm you’re in the right place. So do the following couple of steps:
•

Go to our website and see if your application is listed in the Applications page. If it’s
not then go straight to the Creating a new map for unsupported applications
section below.

•

If your application is listed then go to the Products page of our website. Select your
panel type, then click on the Application Support tab. Finally choose your
application from the menu. Read the information that is now listed on the web page.
It’ll likely lead you to one of the following conclusions:
o

My application doesn’t need the Tangent Hub, but still supports the panels.
Your application will be talking directly to the panels. You must disable the
Tangent panel support within the application. You cannot create a keyboard
shortcut map and still have panel support enabled in your application. This will
most probably be unsatisfactory so we don’t recommend doing this and making a
shortcut map.

o

My application needs the Tangent Hub, but mapping is not possible.
Your application is talking to the panels through the Tangent Hub, but it is not
making use of the Mapper. You must disable the Tangent panel support within
the application. You cannot create a keyboard shortcut map and still have panel
support enabled in your application. This will most probably be unsatisfactory so
we don’t recommend doing this and making a shortcut map.

o

My application needs the Tangent Hub and mapping is possible, but
there’s no map for my panel.
This situation normally arises if your application doesn’t come with a default map
for your panel. You don’t need to make a map based on keyboard shortcuts, you
just create a new map and use the Mapper to map controls as normal. The rest
of this guide tells you how to do this. This section of the guide doesn’t apply to
you.

o

My application needs the Tangent Hub and mapping is possible.
You don’t need to make a map based on keyboard shortcuts, you just create a
new map and use the Mapper to map controls as normal. This section of the
guide doesn’t apply to you and the rest of this guide tells you how to do this.

24.1 Creating a new map for unsupported applications
Hopefully you’re here because you read the start of this section of the guide and
know for sure you want to create an empty map for keyboard shortcuts and OSC
controls. If you haven’t read the start of this section do so now – it might save you a
lot of time and effort!
Make sure your panel is plugged in.
Make sure your application is running and in the foreground.
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Run the Mapper and go to the Mapper File > New Control Map… menu.
You should now see the following window.

Select an application:
From the list that pops up when you click on this menu select the Add a New
Application… option.
You should now see the following window.

Click Select From Desktop.
A 10 second count down is started and you’re prompted to click on the application
you want to create a keyboard shortcut map for. Providing you’ve clicked on an
application, when the count has expired you should see the following window.

62

Mapper made simple ver1 rev9

You’ll see the name of the application you have selected. If it’s correct click Finish.
Otherwise click Back to return to application selection window.
You should now be back in the Mapper main window with an empty map.
There will be one mode called Default. You can add more modes if you wish. You
can now assign keyboard shortcuts and OSC commands to the controls on your
panel. You can also arrange these by defining user Modes and by creating Banks.
You’ll find the details on how to do all of this in the rest of this guide.
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Select Application menu and Auto-select Application
The tangent Hub detects which application is in the foreground and automatically
applies the map for that application to the panels. You can disable this function, but
then you’ll have to manually switch between applications yourself using the Mapper.
The Select Application menu is where you can manually select which application the
panels are mapped to. Generally there is no need to do anything in this menu unless
you disable the Auto-select Application option.
25.1 Disable Auto-select Application
In the Mapper go to the Select Application menu. Untick the Auto-select
Application option.
25.2 Manually select an application
In the Mapper go to the Select Application menu. The current application that is
selected has an arrow next to it. Select the application you want the panels to be
mapped to from the list of applications. Only applications that support the Mapper
or that you have created a keyboard shortcut map for are shown.
User Preferences menu
In the File menu, there is a User Preferences option. There are only two options in
this:
•
•

Enable ALTernate Function Lock (not enabled by default)
Follow Application’s Active Mode (enabled by default)

26.1 Enable ALTernate Function Lock
If you enable this, double pressing a button which is mapped to be Select
ALTernative Function will lock the alternative mapping on. To exit the lock,
single press the button again, and you will go back to standard mapping.
26.2 Follow Application’s Active Mode
If this is enabled, the Mapper mode tabs will follow the current active mode in the
application you are mapping.

64

Mapper made simple ver1 rev9
Resetting everything, or Help – I’ve screwed my mapping up!
If you get stuck and want to go back to the default map you can do either of the
following:
27.1 Reload the default map.
In the Mapper go to the File > Manage Control Maps… menu.
Select the default map from the list of maps.
Or…
27.2 Reset everything to factory defaults.
Unplug all the panels.
Quit all applications.
Run the Tangent Mapper.
In the Mapper go the Help > Reset System menu.
Note that choosing the Reset System option will delete all Mapper user
data (maps and preferences that you have created) for all applications
supported by the Mapper. The data supplied by an application (default
map and controls file) will not be affected.
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